Announcement

Collapse
No announcement yet.

Turbo Bracket

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Turbo Bracket

    Im having a little trouble with bracket on top of the turbo. It has two bolts and a nut securing it to a stud. The nut comes up about halfway and the stud spins. It is no longer secured to the turbo. My wuestion is if anyone knows how to remove this stud? I wanted to adjust the waste gate actuator and in my attempt came across this problem. The stud spins in either direction without loosening or tightening. Any help appreciated.

    Jay

  • #2
    Hi Jay,

    This is common. The easiest answer is just to let it unscrew the stud and then put it back in. It will simply act like a bolt at that point. Alternatively, you can unscrew it, clean it up, free the nut and put it in as a stud and then put the nut back on, however corrosion will eventually bring you back to where you are now.

    Greg

    Comment


    • #3
      The stud spins freely. I have tried loosening it for a while. It will not tighten or loosen. I will try it again.

      Comment


      • #4
        Take a pair of clamps and hold it down from spinning while you remove the nut.
        - Nguyen Consulting, LLC -

        Offering IT Infrastructure consulting, implementation, and support for all your IT needs.

        https://www.facebook.com/NguyenConsulting/

        Comment


        • #5
          the studs used on the turbo seem to be very weak from my experience. I had the same issue on my previous turbo, I was able to back it out eventually with some pliers and convincing. I ended up snapping the stud that faces toward you, where the lower part of the heatshield connects, but that was also on my older turbo. The low mile OEM one I replaced it with seemed to have no issues! I guess heat cycles really play a part in these!

          Comment


          • #6
            Originally posted by bryon_500 View Post
            I ended up snapping the stud that faces toward you, where the lower part of the heatshield connects, but that was also on my older turbo.
            That stud came out on me when removing the heat shield. Upon installation it fell into the crevice known as my Abarth, lol. I have yet to find it or replace it yet.

            Comment


            • #7
              Originally posted by jspiffy View Post
              That stud came out on me when removing the heat shield. Upon installation it fell into the crevice known as my Abarth, lol. I have yet to find it or replace it yet.
              Let me know if you find any of my 10mm sockets in there as well lol

              Comment

              Working...
              X