Announcement

Collapse
No announcement yet.

P006D code and MM piggyback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • P006D code and MM piggyback

    So yeah, I was getting P006D codes quite a bit. I read on a Google search that it may be piggybox related so I pulled my MM box that had been happily working fine for over a year prior and the code has stopped appearing. BUT, the car is still running a bit crap. Full throttle starts at 12psi and creeps up to about 15psi on the factory gauge. Had always hovered around 18psi in the past.

    So... two questions. I was hoping to get a few dollars back with reselling the MM piggyback, but I'm not going to sell somebody a bad unit if something is off with it. So wondering if it is just exaggerating something else that is wrong.

    Secondly, does any of this sound familiar with anyone? I still need to check for vac leaks and I plan on cleaning the aos and replacing the PCV, but I'm hoping for some direction of likely problems.

    Getting frustrated with this as I've been fighting with a crap running car for months now. MAP sensor already changed and that helped, but ... car hasn't given me any joy in a long time and the love is fading. Fast.
    I meant to do that.

  • #2
    Boost leak test.

    Comment


    • #3
      Clamp at throttle body and also change the clamps at the plastic charge pipe. Do it for peace of mind as that is a common place for boost leaks

      Comment


      • #4
        Cracked and leaking pcv seems to have been the issue. At least it looks like it so far. Thanks for the advice though.
        I meant to do that.

        Comment

        Working...
        X